Connecting to OCI FastConnect from your datacenter or corporate office should follow the same evaluation rigor you performed when you decided Oracle would be your cloud vendor.  Even if you are not a WAN or Telco expert, we will discuss the basics so you can uplevel your routing and switching knowledge and vendor approach to solve this task.  OCI FastConnect is a superior on-ramp into Oracle Cloud and they have removed a lot of guess work which has made our job easier.  Plus, if you have an existing WAN such as MPLS, Private Lines or SDWAN, depending on the provider, a FastConnect node might be all that’s required.  FastConnect is similar in concept to other CSPs who deliver an on-ramp to their cloud.

Here at Macronet Services, we have designed over 200 hundred FastConnect options for clients Globally ranging from Cloud to Cloud or Hybrid Cloud DataCenters or from Corporate Offices.  Our partnership alignment with Oracle offers clients a free design and setup from OCI FastConnect to your on-prem datacenters or offices.  Plus, we have over 20+ years designing Global Tier-1 ISP connections for public and private networks.  This affords you deep experience and updated performance pricing trends.

First let’s cover key steps we perform for clients to design options to connect to FastConnect from on-prem.   

  • Identify the amount of Data transferring between OCI Regions to your Corporate Datacenter.
    • We calculate the Bandwidth size against the average throughput time required to complete.  For example, do you require 100TBs from your DataCenter to be sent to OCI and by what time?  Each application, database workload for organizations have equally different requirements.  This is important not to over or undersize the connection.  It can also impact your cost from the provider.
  • Design a Topology & Connection Method: 
    • We’ll look for the Fastest, lowest latent, most affordable provider.  This is important as some areas of the world one provider fits better compared to another region.  Why?  Cost Factors, network backbone, support all play into the 
    • Another option is we’ll look at any existing service providers you work with today.  They may have an easy option to connect into OCI FastConnect and we’ll offer our guidance.
  • Connection Options: 
    • Direct Connection (via Oracle): This is where a physical circuit, often fiber is connected directly into OCI FastConnect
      • Connect directly to an OCI FastConnect Availability Domain
      • Requires your own Layer 3 routing equipment which sits on-prem
      • We identify your Bandwidth Speed, Maximum latency, budget and contract term needed from a telcom partner.
      • Drawbacks of a Direct Connection is it’s a physical installation which does have a lead-time.  We can pull up our Fiber Tool and show you which carriers are available to your on-prem location and to Oracle Cloud
    • Partner Connection:   
      • Use a FastConnect Partner’s network to establish a BGP peer to OCI FastConnect.
      • Establish an OCID in the Tenant
      • Set up the BGP Peering and Oracle private ASN into the partner network.
      • Macronet Services support partner team can walk you through the steps as installation on the OCI region completes in minutes.
      • The Drawback is there will be a physical connection on-premise however the OCI region is usually pre-wired.
  • Technical Requirements: 
    • Support for BGP (Border Gateway Protocol)
    • 1Gbps or 10Gbps port speed
    • 802.1Q VLAN tagging capability (vendor dependent)
    • Support for dynamic routing
    • ASN (Autonomous System Number)
  • High-level Basic Setup Steps: 
    • Create a Virtual Circuit in OCI Console
    • Configure your router for BGP
    • Set up VLAN tagging
    • Establish BGP peering
    • Configure routing policies
  • Important Considerations: (We covered some of this earlier, however we’ll assist you)
    1. Redundancy.  If budget exists, we always advise on a N+1/HA design.
    2. Bandwidth requirements 
    3. Geographic proximity to FastConnect locations
    4. Cost comparison between different providers

 

Would you like me to elaborate on any of these aspects, particularly the technical configuration steps?

  1. Detailed Pre-Configuration Steps: 
    • Document your ASN
    • Gather your network prefixes to be advertised
    • Determine required bandwidth
    • Plan your VLAN IDs
    • Prepare BGP MD5 authentication key if needed

What would be an example of an OCI Console configuration for FastConnect?  In general, we’ve included some of the OCI Console and Router Configuration steps.  Your environment may differ and enhancement toOCI occur regularly so it is best to contact us for the latest and understand your on-premise setup.

  1. Login into your OCI Tenant
  2. Navigate to Networking → FastConnect
  3. Click Create FastConnect
    1. Choose connection type:
      1. FastConnect Partner
      2. Port Based
    2. Fill required details:
      1. Compartment
      2. Virtual circuit name
      3. Provider (if using partner)
      4. Bandwidth
      5. Customer BGP ASN
      6. Dynamic routing gateway (DRG)
  4. Your on-premise Router Configuration Steps for OCI FastConnect: 

# Basic & start of a Cisco IOS configuration example

! Configure VLAN interface

interface GigabitEthernet0/0.100

 encapsulation dot1q 100

 ip address 192.168.1.2 255.255.255.252

 no shutdown

 

! BGP Configuration

router bgp <your-asn>

 neighbor 192.168.1.1 remote-as <oracle-asn>

 neighbor 192.168.1.1 description OCI-FastConnect

 neighbor 192.168.1.1 password <md5-password>

 

 ! Network advertisements

 network 10.0.0.0 mask 255.255.0.0

 

 ! Optional: BGP timers

 neighbor 192.168.1.1 timers 10 30

  1. Virtual Circuit Status Verification: 

 

# On Cisco Router

show ip bgp summary

show ip bgp neighbors

show ip route bgp

 

# In OCI Console:

– Check Virtual Circuit status

– Verify BGP session status

– Monitor route advertisements

  1. Test and Validation: 
    • Ping Oracle services
    • Test connectivity to VCN resources
    • Verify route propagation
    • Check bandwidth utilization
    • Test failover if redundant setup
  2. Common Issues and Solutions: 
    • BGP not establishing: 
      • Check ASN numbers
      • Verify MD5 authentication
      • Confirm IP addressing
    • Routes not propagating: 
      • Check route advertisement configuration
      • Verify route security lists
      • Confirm DRG route tables
  3. Security Considerations: 
    • Implement route filters
    • Set up prefix lists
    • Configure maximum prefix limits

# Example BGP security configuration

router bgp <your-asn>

 neighbor 192.168.1.1 maximum-prefix 100

 neighbor 192.168.1.1 prefix-list ALLOWED_PREFIXES in

 neighbor 192.168.1.1 prefix-list ADVERTISE_PREFIXES out

  1. Monitoring Setup: 
    • Configure SNMP monitoring
    • Set up BGP session alerts
    • Monitor bandwidth utilization
    • Track route stability

A basic and starting point for Juniper Configuration Example for On-Premise to OCI FastConnect:

junos

# Interface Configuration

set interfaces xe-0/0/0 unit 100 vlan-id 100

set interfaces xe-0/0/0 unit 100 family inet address 192.168.1.2/30

 

# BGP Configuration

set protocols bgp group OCI-FASTCONNECT type external

set protocols bgp group OCI-FASTCONNECT peer-as <oracle-asn>

set protocols bgp group OCI-FASTCONNECT neighbor 192.168.1.1

set protocols bgp group OCI-FASTCONNECT authentication-key “<md5-password>”

 

# Route Advertising

set protocols bgp group OCI-FASTCONNECT export EXPORT-POLICY

set policy-options policy-statement EXPORT-POLICY term 1 from protocol direct

set policy-options policy-statement EXPORT-POLICY term 1 then accept

 

# Security

set protocols bgp group OCI-FASTCONNECT maximum-prefixes 100

  1. Arista Configuration Example:

 

! Interface Configuration

interface Ethernet1

   description OCI-FastConnect

   no switchport

   ip address 192.168.1.2/30

   

! BGP Configuration

router bgp <your-asn>

   neighbor 192.168.1.1 remote-as <oracle-asn>

   neighbor 192.168.1.1 password <md5-password>

   

   ! Route advertisement

   network 10.0.0.0/16

   

   ! Optional BFD for faster failover

   neighbor 192.168.1.1 bfd

  1. Detailed Monitoring Commands:

 

Part of Macronet Services commitment to perfecting the client experience when you partner with OCI, we do offer free WAN evaluation and benchmarking.  Many OCI clients have benefited from our expertise to find cost optimization withing their corporate network, resulting in millions in savings that can be applied to your Oracle Compute costs.  

 

Contact us and we can provide you an overview and a customized use case to show how we could help your organization.